Forums: Index > Help desk > Where is tech support? - here, looking at our problem forms

Forums: Index > Watercooler > Where is tech support? - here, looking at our problem forms

Initial queries and tentative responses[]

The apology banner says our expert is away. I assume that means Phlox, who on February 18 said he would be returning the following week. Is he Wikia's only expert capable of dealing with this problem? It shouldn't take a technical genius to scan the histories of the forms pages and corresponding templates to find what was changed on March 23 or 24 to cause the forms to stop working, and then to undo that revision.DennisDoty 13:09, March 26, 2010 (UTC)

What is the problem exactly?
If you edit and create pages without the form, there is no problem at all. For creating pages, just open the page (without form) from a relative and copy and paste the template. rtol 20:36, March 26, 2010 (UTC)

I suspect that we have had a new version of "Semantic Forms" installed (see Special:Version - we are running a March 2010 version). Thurstan 21:11, March 26, 2010 (UTC)

Can't we go back to the old version until this problem is solved?DennisDoty 21:42, March 26, 2010 (UTC)
Installations are beyond our control. rtol 09:10, March 27, 2010 (UTC)
Multi-part response:
  • Form:Person hadn't been changed for months; I've not checked any of its templates' histories
  • Wiki no longer recognizes Special:AddData and Special:EditData - crucial to our proper use of forms
  • Thurstan has probably suspected correctly; so maybe a posting to the SMW mailing list will get an expert interested
How do I find the SMW mailing list? I sent an email to Wikia asking for help. DennisDoty 12:04, March 27, 2010 (UTC)
I've now added a link on our SMW page to it, Patterson (Talk) 13:46, March 28, 2010 (UTC)
  • Creating pages for individuals seems to work fairly well if you use the Advanced form (described as "verbose" on the menu)
  • rtol may have failed to look carefully at Aimery IV de Thouars (c1024-1093) before saying there is no problem; and has he tried to give it a sensor page?
  • Links to people in the infobox seem OK if the target page exists, but have that "tag" structure if it doesn't
  • Those of you who read our email list postings will know what I sent to Central Wikia by way of plea for help; when Central replies, I'll point to this forum.
How do I find the email list postings? Thank you, Robin, for all your efforts.DennisDoty 12:04, March 27, 2010 (UTC)
Thank you. I've replied on your talk page. — Robin Patterson (Talk) 13:46, March 28, 2010 (UTC)
Robin Patterson (Talk) 11:37, March 27, 2010 (UTC)
There is a problem with the display, but not with the date on Thouars. I added a sensor page without any problem.
I bet that they renamed AddData and EditData. rtol 12:31, March 27, 2010 (UTC)

There is a discussion about this at rtol 06:02, March 28, 2010 (UTC)

Hooray! Thurstan and rtol solve (most of) the riddle:
"Special:FormEdit - lets a user either create or edit a page using a user-defined form. (See example of page.) (This page was, until version 1.9, two separate pages: "Special:AddData" and "Special:EditData".)"
Long past my bedtime, so one of you guys can start tinkering! — Robin Patterson (Talk) 13:52, March 28, 2010 (UTC)
Some observations:
  • When a new article is created by entering a name using Create new article Person form (standard) and clicking "Create an article about a person", we now get Special:FormEdit/Person/entered-name. In other words, nothing has to be changed in Form:Person to make it go to Special:FormEdit rather than Special:AddData.
  • When displaying Special:FormEdit after using Create new article Person form (standard) (as described above)
  • The save button at the bottom of the page does nothing.
  • The save button at the top of the page causes the page to be saved, but without any of the entered information.
  • The save button at the bottom of the page does nothing.
  • The save button at the top of the page causes the page to be saved, but without any of the entered information.
DennisDoty 23:03, March 28, 2010 (UTC)
That's odd. (Well, some of it is.) I've created a couple in the last 20 hours without much bother. Have a look at my contributions over the last 3 hours, for example. One possible difference - they were existing non-form pages being brought into the forms system. Nobody has changed Form:Person in the relevant period. But there may have been some behind-the-scenes work on the installation, resulting in the Special:FormEdit/Person/whoever. — Robin Patterson (Talk) 07:19, March 29, 2010 (UTC)
How did you bring existing non-form pages into the the forms system?
A couple more observations:
  • When one uses "Edit with form" on an existing page, one gets Special/FormEdit/Person/... with all the existing values displayed on the form. If one then changes a single value (short name) or makes no changes at all:
  • The save button at the bottom of the page does nothing.
  • The save button at the top of the page causes the page to be saved, but without any of the existing values except sex, ifmarried-g1, and globals.
  • Clicking "Advanced form" on the Edit Person page while displaying an existing person takes one to Special:AddPage/Person_advanced/... and of course the "No such special page" error message
DennisDoty 10:48, March 29, 2010 (UTC)

Bringing old-style articles into the forms system[]

  1. Copy the pagename to your clipboard.
  2. Open a new window in Familypedia and click on the sidebar item "Create new article".
  3. Paste the name into the box replacing "<type person article name here>", and click the "Create ..." button.
  4. You reach a "form" page with lots of buttons and little edit boxes. (There should be a warning saying the page exists but doesn't use the form: right! No worries; everything that was on the page is still there, and you will see it in a medium-sized edit box near the bottom. Best not to touch parts of that that you don't understand. Probably safe to delete sections that will be redundant, such as "Parents", but safer to leave it alone until next edit.)
  5. Fill in the first name, surname, and short name (copying from your original article where convenient). Those three are compulsory.
  6. Fill in the gender and anything else you like (copying as before). Where you are naming people (e.g. parents, partner(s), and child(ren)), please include dates just as on a standard page name (without brackets), and join people with plus signs (nothing else).
  7. Include your user name in the Contributors box; typing a few letters of it will probably give you an "autocomplete" for quick finish.
  8. Please add a brief edit summary near the bottom (e.g. "intro" or "upgrade") - otherwise the "Recent changes" item may take up three lines and annoy other users.
  9. Don't bother with "Preview"; it's no guide to page appearance. Just click "Save page" at the bottom.

I'm using the above as the basis of a new page Help:Upgrading old-style person articles. — Robin Patterson (Talk) 12:19, March 29, 2010 (UTC)

It looks like Constance Osterkamp (Waite) (1909-1983) was converted in the way you describe this morning. If you try to edit her with advanced form, the system uses Special:AddPage, which of course gives the "No such special page" message. I didn't try to Edit with form, because I am fairly certain it would wipe out all the information except sex, ifmarried-g1, and globals.DennisDoty 13:00, March 29, 2010 (UTC)

That's one that I converted, indeed. I've just given her a simple-form edit. Page looks as good as ever, or better; no "tag-links" in the infobox. Maybe your computer or browser is contributing to the differences we seem to have. I have a Toshiba Satellite Laptop with Firefox 3.6 or 3.7. I'll try Advanced form. — Robin Patterson (Talk) 13:16, March 29, 2010 (UTC)
Advanced form does indeed start badly:
So flying by seat of pants I just change "AddPage" to "FormEdit", and all's well (on the face of it). Connie has been upskilled. — Robin Patterson (Talk) 13:24, March 29, 2010 (UTC)
This is curious. I did what you did: I changed AddPage to FormEdit and then I unskilled her, i.e. deleted skill(s) on the form. The save button at the bottom of the page did nothing, but the save button at the top of the page wiped out all her information except sex, long-name, and globals. Sorry about that, but you should be able to easily undo it. DennisDoty 13:47, March 29, 2010 (UTC)
The differnce could be caused by my computer (as you suggest in the undo) or my browser, but I think it is more likely to be in my preferences. Could you take a look at them? DennisDoty 14:26, March 29, 2010 (UTC)

An answer I hope[]

I received this reply from Wikia:

Hello Dennis,

In order to properly fix the Semantic Forms issues, you must do the following, which are actually very simple steps:

1) Null-save (aka open and submit without changing anything) to each form.

2) Change any links from Special:Allpage and Special:Editpage to Special:FormEdit.

We apologize for these issues (our version was so far behind; hence the issue) but it fixed a number of bug-gy problems for other wikis with Semantic Forms.

-- Best Regards and Happy Editing, Tim "daNASCAT" Quievryn Wikia Community Team

I can do 1), I think, but I don't know how to do 2). So, I'll let you guys handle it. If this works, I retract anything negative I said about Wikia tech support. DennisDoty 16:10, March 29, 2010 (UTC)

I null-saved Form:Person, but it had no effect on my ability to Edit with form. (Of course my "issues" with "Edit with form" may be unique to me.)DennisDoty 17:18, March 29, 2010 (UTC)

Tim's advice is that we should do both to have an effect. I'm time and hardware constrained at the moment and probably for another week or so. Someone'll need to a search on the two special words and replace them. rtol 07:34, March 30, 2010 (UTC)

Some progress: I changed AddPage to FormEdit in Template:Showfacts formbuttons and this gets rid of the "no such special page" error. Now, for me anyway, adding a person using Create new article Person form (verbose) causes the person to be added but without any of the entered information, just sex and globals. And editing an article by clicking Advanced form on the Edit with form page, causes most values to be deleted. The save button at the bottom of the page still doesn't work, but I expect this can be fixed by changing the corresponding template. DennisDoty 13:16, March 30, 2010 (UTC)

The save buttons at the top and bottom of Form:Person advanced are both created with the standard input|save tag. I thought maybe you couldn't use the standard input|save tag twice in the same form, so I deleted the first one, but that did not cause the save at the bottom to work. Of course I undid my deletion. So, the save button at the bottom of the form doesn't work for me. Does it work for anyone else? DennisDoty 17:05, March 30, 2010 (UTC)

Good work, Dennis. But I have never had a problem with the bottom "save" button, nor wiped lots of data as your saves have done. I don't recall other users reporting those errors either. You do seem to have problems with your system. Anyway, I'll look through other showfacts templates. — Robin Patterson (Talk) 23:21, March 30, 2010 (UTC)
Would you look at my preferences and skin? I remember last year there was a problem where I had to alter my preferences and someone wasn't seeing something because they had the wrong skin. I haven't changed anything about my computer or browser, so I don't see how they can be causing the data wipeout. Before the new version of Semantic Forms my system was processing forms normally. DennisDoty 01:03, March 31, 2010 (UTC)
I have the same problem as Dennis. Bottom save does not do anything, top save wipes all data. This is on Windows XP using the MS Internet Explorer. rtol 05:13, March 31, 2010 (UTC)
Me too Thurstan 06:11, March 31, 2010 (UTC)
Me three. Lanica 13:33, March 31, 2010 (UTC)

I have sent the following to Wikia:

We at Familypedia have performed both of the tasks described in your response and still have the following problems:

1) When performing FormEdit, the Save, Preview, and Show changes buttons at the bottom of the form don't do anything. The Save button at the top of the form will add a new page if one by that name does not exist, but that page will not have any of the entered data, just globals and default values. If the corresponding page already exists, the save button at the top of the form will update it wiping out the data in almost all fields.

2) Robin Patterson does not experience the above problem, but 4 users have reported it.

3) Robin has reported that when displaying a template created by a form some fields contain span tags (see Wikia Support Request #44180) The response from Chris Stafford is that a value passed to #formlink shouldn't have a span inside it. We have not yet made any changes to fix this problem. I include it here because it began occurring when the new version of Semantic Forms was installed.

4) On the forms some fields now run off the page background on the right, which wasn't the case before the new version of Semantic Forms was installed. This is my own observation, no one else has reported it.

Thank you for your timely response to my initial request.

Dennis Doty User:DennisDoty at Familypedia

DennisDoty 16:25, March 31, 2010 (UTC)

Response from Wikia[]

Hello Dennis,

Glad to hear back from you (though unhappy that we have to discuss fixing these issues...sigh...if only things worked the way they ought to). Let me try to address your concerns point by point:

> 1) When performing FormEdit, the Save, Preview, and Show changes > buttons at > the bottom of the form don't do anything. The Save button at the top > of the > form will add a new page if one by that name does not exist, but that > page > will not have any of the entered data, just globals and default > values. If > the corresponding page already exists, the save button at the top of > the > form will update it wiping out the data in almost all fields. > > 2) Robin Patterson does not experience the above problem, but 4 users > have > reported it.

I have seen #1 happen - the wiping out a completed page, that is - before every so often on The Third Turn. I would normally chalk these rare instances up as server issues (Wikia servers sometimes do crazy, insane things to Semantic Data...I just figured this was one case of it). These are very isolated incidents for me and I have never had the New-Page-Returns-Defaults Issue. I can not comment on why Robin doesn't have this happen yet and why others do, since usually I alone am doing most of the editing and the only one to see these issues. I will need a little more information on this before I can begin to investigate what exactly is going wrong - Is it consistent (are these four users having this happen EVERY time and if so, what browser), is it one specific form and a few links would be great too.

> 3) Robin has reported that when displaying a template created by a > form some > fields contain span tags (see Wikia Support Request #44180) The > response > from Chris Stafford is that a value passed to #formlink shouldn't have > a > span inside it. We have not yet made any changes to fix this problem. > I > include it here because it began occurring when the new version of > Semantic > Forms was installed.

That's an interesting note; I have yet to use Formlink yet since the Form system on The Third Turn is still under major performance development. Is it horribly inconvenient to remove the span tag for this one template (aka lots of manual editing) or is it a simply "replace with some other quick code piece"? I'll ask the developers what they know once we can come up with a solid list of all the "oopsie" things that happened after this update.

> 4) On the forms some fields now run off the page background on the > right, > which wasn't the case before the new version of Semantic Forms was > installed. This is my own observation, no one else has reported it.

This sounds like a browser-based bug to me, something the developers just simply didn't take into account when doing the update. I have you as running IE 7.0 , and the release log notes they made a ton of improvements to make sure it displays better in Internet Explorer. This is probably an oversight on their end. If you could send me a screenshot of that as well, though, I can confirm and talk to the developers.

I'm genuinely sorry to hear about all these issues. I have noticed that the update does indeed include performance improvements on our end of the server and it did fix some bugs, but I certainly would have been more careful pushing the update through had I known these extra bits were going to go wrong. Hopefully, these are just minor "nit-picky" things for the most part (except for the NewPage/EditPage issue from #1...that sounds pretty serious) and we can tweak them quickly.

> > Best Regards and Happy Editing, > > Tim "daNASCAT" Quievryn > > Wikia Community Team

Responses to Tim and later investigations[]


Here is my reply:

Hi Tim,

Thank you for getting back to me so quickly. I will give you as much of what you ask for as I can. Some will have to come from other Familypedia users. We have been discussing these issues at where I have been posting our correspondence. Problem 1) is completely consistent for me: happens every time and I have tried many variations of using Form:Person and Form:Person advanced. I am running IE with Windows Vista on an HP Pavilion model a6010n. Robin has a Toshiba Satellite Laptop with Firefox 3.6 or 3.7. User:rtol has Windows XP using MS Internet Explorer. I have been working exclusively with and Regarding removing the span tag, I wouldn't know where to begin, but one of our sysops might be able to tell you how difficult that would be. I'm not sure what you mean by a screenshot, but I am attaching a .mht file of an Edit Person page that shows the form running off the right side of the page. If you need any other information, I'll get it to you as quickly as I can. DennisDoty 23:34, March 31, 2010 (UTC)

Here are my two cents...I am using Opera as my browser, Vista as my OS and a Dell home computer. I have only used the forms to create new pages, and then only two of them. The first was before the 'troubles' and seems fine. The second was on the 30th and left me with globals and default values. I'm a new user, so I have nothing really to compare this to. I just know it's not working right now. Thanks for your help. Lanica 00:09, April 1, 2010 (UTC)

Span tags[]

Seem to have gone away. Links to people who don't yet have pages are now nice green buttons in the same style as the "Save page" and "Preview" that I can see below this edit box. I don't remember checking whether I've tried to click one. — Robin Patterson (Talk) 13:07, April 1, 2010 (UTC)

I have now tried several: they very properly take you to the same place as you would get from the sidebar link "Create new article". — Robin Patterson (Talk) 12:24, April 2, 2010 (UTC)
One or two disadvantages of those buttons: you can't highlight to copy them and you can't right-click on them. — Robin Patterson (Talk) 15:13, June 27, 2010 (UTC)

Possibly related is the fact that the line of links that include "Create/Update Sensor page" used to be all nice green buttons like the above, but now they are often plain links. — Robin Patterson (Talk) 13:07, April 1, 2010 (UTC)

Using Internet Explorer I still see the span tags, as in Edward Doty (bef1600-1655), who is now married to a span tag. DennisDoty 16:30, April 2, 2010 (UTC)

"Refresh" fixes that one. Thurstan 21:06, April 2, 2010 (UTC)

Losing stuff[]

I wonder whether there may be a clue in this comment in Form:Person:

<!-- the following are hidden, but we need to process them so that the parameters are not thrown away after a form edit -->

Robin Patterson (Talk) 13:07, April 1, 2010 (UTC)

Yes, I think it may be. I've now added a section to Help:Starting pages for people, places, or surnames/Guidance recommending that people not use "Edit with form" more than once on a page. When you use that link, the program looks at every one of the templates it's designed to deal with, changes any that it's required to, then replaces them in their proper order at the top of the page or at the bottom, leaving everything else collected in the middle.

A greater part of the apparent loss may be that not everything you create during one edit will appear on the page display immediately but (if you are using the right browser!) it is still part of the page and is almost certain to be found and displayed at next edit. That's explained elsewhere now.

Robin Patterson (Talk) 05:22, June 10, 2010 (UTC)

There Are Some That Call Me "Tim"[]

Hey guys, did a few tests this morning just to confirm what you guys are seeing. This problem does not replicate itself on Firefox for me but it does rear its head on Internet Explorer. Testing this, I went to The Third Turn and made some tests on my forms with Internet Explorer (which I never use) and could not trigger the same problem. Thus, due to the very complex forms you guys have here, there must be something SOMEWHERE that is causing this. Perhaps Robin's explanation, perhaps something else. I am going to sit down here in a few hours and just go piece by piece through most of these forms and see if I can find the hang-up, but as a warning, I am certainly no expert on browser compatability. I'll let you guys know what I'll do next - to be frank, I'm glad these issues happened with this upgrade. As a Semantic developer, I can tell you creating complex code is insanely easy but hard to fix. The simpler we can make this code, the better. --daNASCAT   14:32, April 1, 2010 (UTC)

All right, I just looked through the code for the third time this morning; see nothing that could be changed for IE reasons. Can we confirm these issues are still happening on Internet Explorer only? --daNASCAT   20:39, April 8, 2010 (UTC)
I just tried to create a new person (Agnes Mary Ockenfels (1912-2008)) using the form. It was all ignored - the male icon was all that appeared, even though I'd clicked female. I tried editing and re-saving, nothing happened. The lower save button doesn't react at all, the one on the top deleted all my material. Lanica 20:53, April 8, 2010 (UTC)
I tried adding a new person and editing an existing person using Form:Person with the same results as before: bottom save button doesn't work, top save button wipes all data, both newly entered and existing. An observation that may be a clue: before version 1.9 when entering father or mother you would see a clickable list of existing pages that begin with the same letters, not so any longer. DennisDoty 21:11, April 8, 2010 (UTC)
I'm still getting (with Firefox 3.6.3) most new person pages created moderately well with simple form and additional info with advanced form (with both of the "Save page" buttons working), with only one occasion when there was a deletion as others report. "Update/Create Sensor page" sometimes works and sometimes doesn't (and using Form:Sensor page isn't working properly). One way I encourage it to work is by creating a tree subpage first! My other grizzle is that the "Edit facts" links (and the "Update sensor page" link on a sensor page) haven't yet had their Special links changed to "formedit". Maybe I should look for them to fix them. — Robin Patterson (Talk) 01:47, April 9, 2010 (UTC)
I found the "EditData" for the Edit facts in the infobox, and for the "Update sensor page" link on the sensor page itself, and fixed them. But I can't find one for the Child box. I've added a note about replacing it with formedit, but not everyone will see that. I hope Tim has some joy for us soon. — Robin Patterson (Talk) 15:21, April 20, 2010 (UTC)

Tim, would you give us an update on what you have been doing to solve our problem? DennisDoty 15:11, April 20, 2010 (UTC)

Hey guys, sorry about the long delay. For some odd reason I recalled this issue as being primarily resolved pending the next Semantic Forms update - didn't realize there were still other issues. I'm meeting with the Semantic Forms designer this weekend - they have had a hard time seeing exactly what we've been seeing. Hopefully I'll get a straight answer then. --daNASCAT   22:06, May 20, 2010 (UTC)
So, Tim, how did your meeting with the semantic forms designer go? Can you get him to replicate the problem by having him use Internet Explorer to access our Form:Person? DennisDoty 15:13, May 26, 2010 (UTC)
I did meet with him and showed him the issue. He believes it has to do with exactly what version of IE you are working with. Can I get confirmation about what IE browsers people are using? --daNASCAT (Help Forum) (blog) 18:38, June 1, 2010 (UTC)
I'm using Opera, but Identifying as IE. I'm not sure what version that would be. When I use Opera without the change in ID it has even more problems. Lanica 19:11, June 1, 2010 (UTC)
I'm having trouble determining what version of IE I'm using. Windows Help says that to determine version for IE7 and IE8 one should bring up IE, press ALT+H, and then click About Internet Explorer. When I do this, I don't see "About Internet Explorer", so maybe I'm not using IE7 or IE8. The program ieexplore.exe was last modified on 3/9/2010. I have Windows Vista Home Premium and all updates have been applied. Have you, Tim, or the Forms developer been able to sign on to Familypedia using IE and get our Form:Person to work? DennisDoty 21:44, June 1, 2010 (UTC)

Interim work-around for non-users of Firefox[]

Forum:Data entry without using Form:Person. — Robin Patterson (Talk) 04:07, June 27, 2010 (UTC)

Progress with finding the real problem[]

continued from above

"Edit facts" links[]

It occurred to me (as I was reading one of Phlox's old notes) that the "Edit facts" links may be safe for non-Firefox users to work with. Would several of you please test the infobox one to check? If it's OK, we may be able to eliminate something from consideration (AND you guys may have an easier time adding fields). (The child box one should be checked too, but I always, and you guys probably, have to fiddle with the resulting URL to change to Special:formedit.) — Robin Patterson (Talk) 15:13, June 27, 2010 (UTC)

How to find discontinued special page links[]

Normal search just tells you you can't. How else can we find things like the instruction that gives a bum steer when you click "Edit facts" in a child box? — Robin Patterson (Talk) 15:13, June 27, 2010 (UTC)

Is it time for Wikia to give more attention to the fourth-biggest Wikia site?[]

Three months of disability. We could be losing potential contributors. — Robin Patterson (Talk) 15:13, June 27, 2010 (UTC)

Escalating this Issue[]

Heya, I have escalated this issue and hopefully will have more information shortly. In the meantime, please do post any additional information that you have about the current status of the issue here. Thanks. -- --JeskaD 17:57, September 1, 2010 (UTC)

Hey all, I did some investigating with Yaron from Semantic Forms Monday when he released another new version of Semantic Forms (2.0) that was causing some issues. We finally believe that ANY form that is calling in the {{{for template}}} line a template that contains a "/" in its name will cause the breakage you see. That was fixed in a bug patch, but of course we have not upgraded Semantic Forms ourselves and will not for a while. I would suggest moving the templates and seeing if that fixes your issues. --daNASCAT (Help Forum) (blog) 20:28, September 1, 2010 (UTC)


Hurray! I'm hoping this means the form problem will no longer be an issue (please let myself or Tim know if this is not the case).

(copied over): I'm still curious if there is anything else new feature-wise that could help with your day-to-day editing of the wiki or maybe help to engage new users or even something to make it easier for admins. This could be in the form of either a Wish List (things you'd love to do but aren't currently possible) or Pain Points (things that currently don't quite work the right way or are work arounds) Please do let me know if you or any of the other admins have anything, would love to work with you to get them done.

- --JeskaD 18:45, September 2, 2010 (UTC)

So what does this mean for those of us that were having problems? DO we try again or are we waiting for someone to do something? Lanica 15:52, September 3, 2010 (UTC)
I was wondering about that too, though I have Firefox and am much less affected. Has anybody done anything to the "for template" thing that was mentioned above? — Robin Patterson (Talk) 04:48, September 6, 2010 (UTC)
The techies revel in their usual obscurity. Most of Phlox' templates have a "/" in, so there is no easy workaround. The problem remains so. The alternative solution is simple: Use Firefox. rtol 07:28, September 6, 2010 (UTC)

Nothing that has been mentioned about template names has anything to do with which browser you are using, so as far as I can tell, there has been no progress with the issue. Thurstan 23:54, September 27, 2010 (UTC)

Now suddenly without discussion or even warning Wikia cuts off our SMW for 3 hours, and it's still not properly restored 24 hours later despite the report that it is restored. Interesting that this comes so soon after Wikia's "New Look" is imposed. See Forum:SMW on Familypedia for the ongoing story. — Robin Patterson (Talk) 01:48, November 14, 2010 (UTC)


User:PedroM has changed the coding for the "form buttons", which seems to have fixed the "form only works with FireFox" problem. Thurstan 20:39, May 15, 2012 (UTC)

Yes, I can confirm that! However, we seem to have lost the important buttons for creating sensor pages and tree pages and descendant pages. Where should I look? -- Robin Patterson (Talk) 00:53, December 26, 2012 (UTC)

They are still there, after "Other article pages:". They have just lost their labels when {{string}} stopped working. I will look create fixed labels. Thurstan (talk) 01:05, December 26, 2012 (UTC)

Thanks, Thurstan, for revealing those buttons: not as pretty as they used to be but working just fine. We still seem to need more republishing at times, but that's a small issue. Changing the sensor page preload to just {{sensor}} is working fine for me, and I replace old wordy sensor page content as I see it. -- Robin Patterson (Talk) 10:20, January 2, 2013 (UTC)

Sources and footnotes labels[]

The published pages used to have descriptive labels saying which footnotes were being referred to. Currently (in Firefox 12) they just have a sort of part-URL (which admittedly does usually contain a hint of what the notes or sources refer to):


The URL-thing is dressed up as a link with a pipe at the end; I suspect it wants to display something based on a string thing - or preferably at present an English-language version. Who's our string expert? (He knows who he is!)

-- Robin Patterson (Talk) 10:20, January 2, 2013 (UTC)